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Using The PhotoShop© Image Scatter Script 
   

One of the free resources you can download from textures.com is a 
script that works with PhotoShop C6 and later. Check your PhotoShop 
version because it really won't run with earlier versions. The script 
generates beautiful seamless textures you can use both on- and off-
computer. Want to make your own wrapping paper or fabric? For 
either, you need a faultlessly repeating motif, and this script makes 
one automatically. Need a background for an image, a title, a web 
page, or report cover? How about designing custom wallpaper for your 
computer desktop?  This script does the trick really quick. 

The author of the Image Scatter Script, Marcel Vijfwinkel, has 
prepared an illustrated online tutorial to guide you, but here I will 
share tips from my own image scattering experiments. I hadn't used 
scripts in PhotoShop, and was a bit intimidated because it sounded 
very technical.  However, using the script turned out to be easy and 

worth the effort of learning how. I 
generated the beautiful seamless 
pattern shown here on my first try! 

In this tutorial, I'll review the 
steps in downloading and using the 
Image Scattering Script. Then I'll 
show you how to save the pattern 
you make as a PhotoShop pattern 
preset. The first step is to go to 
textures.com and download the 
scatter script, so let's do that now. 
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Downloading The Image Scatter Script 
On the home page of textures.com, scroll to the 
bottom of the page and click the link for 
Resources. You'll want to return later and try out 
the other freebies on this page, but for now, 
click the link on the third item, Free PhotoShop 
Image Scatter Script.  

The window that opens is the online 
tutorial as well as the download page. 
Click the Download button, and be sure 
you make a note of where you save the 
file, random_pattern_fill.jsxbin. If you 
know where your version of PhotoShop 
stores its Presets, you could save the 
script there, in the Scripts subfolder. In 
the PhotoShop version I use, on Mac, 
Presets is a folder in the main 

application folder, but the location is different in other versions and 
platforms. That's okay; you can run the script from any location, just 
so you remember where it is. 

Where Are Scripts In PhotoShop? 
Learning to use the Image Scatter 
Script opened up a whole new area of 
PhotoShop for me. One of the many 
hidden features of PhotoShop, 
Scripts are found under the File 
menu.  The Scripts menu lists scripts 
that come installed in PhotoShop.  

You will not see the Image Scatter 
Script in the list unless you copied it into the Presets-->Scripts 
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folder. Instead, to run the script, go under the File menu, scroll down 
to Scripts and open its submenu, and choose the Browse option at the 
very bottom. Then navigate to where you saved the script and open it. 

The Easy Way To Seamless Patterns 
Take plenty of time to read through the online tutorial. As you see, the 

overall strategy is to lay out a grid of small, 
individual images, then run the script to 
automatically scatter them into an overall pattern 
that is seamless on all edges. That means that if 
you place copies of the pattern edge to edge, the 
pattern will continue so that you don't see an 
obvious line where two pattern blocks join. 

The most time consuming part of the operation is creating the grid of 
images.  The script does the difficult part for you! If you have ever 
attempted to make a repeating motif, you'll appreciate the power of 
this little script. 

Planning The Design Grid 
Before attempting to create a grid, let's do a bit of pre-planning.  The 
script includes an option to automatically generate guides to define the 
grid, so first you need to decide how many grid boxes across and down 

it will be and choose the overall size of the grid. The default overall 
size is 3,000 pixels square, but you can change that, and it need not be 
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Quick Tip: How to decide on the size? It depends on what you plan to do with 
the repeating pattern. For example, for wallpaper or fabric, you probably need 
a larger repeating block size than if you were designing a background for a web 
page, since the design will be viewed in a much larger size for the fabric or 
wallpaper.  A design block for wrapping paper should be midway between the 
size for fabric or for a web page background.  
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a square, as you see by the online example. The size and proportions of 
the grid control the size of your pattern repeating block or motif. 

The total size of the grid also determines the best maximum size for 
the small images you will put into it.  I've found it easier to calculate 
the maximum size for the small images and re-size each one before 
adding them to the grid.  That way you can simply drag in each one and 
concentrate on positioning it completely inside its grid space. 

Here is the formula: The overall width divided by the number of grid 
boxes across = the best maximum width for each small image.  If 
your grid will be square (width and height equal), then that's also the 
maximum height for each small image. If the height and width of your 
grid spaces are not the same (that is, the grid is not square), also 
divide the grid's total height by the number of grid boxes high to 
calculate the maximum height to allow for each small image.  

Re-Sizing The Small Images 
To re-size each small image, open it in PhotoShop, go under the Image 

menu and choose Image Size. Be sure Constrain 
Proportions is active, and type the new dimension in 
either the width or height. You 
should change whichever of 
these dimensions is larger to 
the maximum dimension you 
calculated. With Constrain 
Proportions active, the other dimension will 

automatically change proportionately.  

Then Save each small image in its new, smaller size.  If a small image 
you plan to use is already smaller in both dimensions than the 
calculated maximum, you don't have to resize it. Do avoid using an 
image that is many times smaller than the grid box.  If you encounter 
that situation, choose a smaller overall grid size and recalculate. 
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Prepare and re-save all the small images you intend to use before 
creating and filling the empty grid.  

Creating The Empty Grid 
When you have decided on a pattern size and the number of spaces in 

the grid, you're ready to use the script for the first 
time, to generate the grid guidelines. Create a new 
PhotoShop document in the size you have chosen, making 
sure that it has a transparent background. The images 
need to float with empty space around them. Otherwise, 
when they are scattered you would see the edges of a 
background rectangle around each of them. 

 
With the new document open, open the 
Scripts submenu under File and scroll down 
to Browse. Navigate to your script and run 
it.  When the Random pattern fill window 

opens, type in the dimensions of your grid and the 
number of Columns and Rows the grid will have. Then 
click the Create Guides button.  Instantly the grid 
will be marked off in your document, ready for you to 
drag in the images. You can click Cancel to close the 
script and Save the document at this point, 
preserving the positions of guides for the grid. 

Sources Of Images 
Technically, the main requirement for the images to scatter is that 
they must float on a transparent background.  Aesthetically, you should   
give some thought to how the colors of the scattered items will blend 
and to the complexity of the items.  I got very good results with 
flowers and leaves, simple shapes without much detail. The pattern was 
less pleasing when I tried scattering small clip art pictures, because 
the clip art I chose was a bit too complex. When the items were 
scattered so they overlapped, I felt that it looked messy.   
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A rich source of free images to scatter is textures.com, the site where 
you downloaded the script. Some categories in the sidebar lead to 
images already on transparent backgrounds. Under Nature, check out 
the subcategories Branches, Leaves, and Flowers. The Flowers 
category includes both fresh and dried flowers that make excellent 
patterns.  Under Leaves there is an extensive collection, some in fall 
colors, with transparent backgrounds. Some of the single plants, desert 
plants, and tropical leaves are also ready to use. Look what is hiding 
under the Animals-->Insects category: A collection of colorful 
butterflies! For scattering, download the smallest size of each image.  

What If There Is A Background? 
Besides the images that have no background, there are many other 
photos on textures.com that potentially could make good scatter 
patterns.  In the Categories sidebar, click Various-->Food-->Fruit.  
The sliced kiwi, strawberry, lime and orange photos might look good in a 
scattered pattern, and so might the whole fruits like the various 
different apples.  How about vegetables?  Under Various-->Food--
>Vegetables is a single mushroom, a head of lettuce, a carrot, a 
tomato, even an okra pod. We would just need to get rid of that 
background. Fortunately there are several ways to do that. 

Let's remove the background from one of the fruit 
slice photos.  We'll assume you have signed up for a 
free membership on textures.com, which gives you 
15 free credits each day. You can download the 
smallest lime slice photo for one credit, and it is 
large enough that you will need to downsize it 
before using it in a pattern.  Open the downloaded 
photo in PhotoShop and select the background.   

This photo's background was very easy to select since it is mostly one 
color and I could use Magic Wand for this selection. For a busier 
background, plan to use a combination of tools such as Select Color 
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Range, Quick Selection tool, or various 
lassos. When you have a good selection, go 
under the Layer menu and add a mask that 
will Hide Selection. Re-size the lime photo 
to the maximum dimension you have 

calculated that will fit into the grid you have set up and save the image.   
You can prepare clip art as well as photos in this way to use with the 
Image Scatter script. 
 

Drag Images Into The Grid 
When you have all the images prepared, you have completed the 
hardest part of creating a repeating pattern.  Open all of them and 

arrange them in the order you plan to use 
them.  Be sure you have the Layers window 
open to do the next part. To add an image to 
the grid, drag the layer containing the 
image from its Layers window into the 
document with the grid marked.   

Position each small image so that it is 
entirely inside its grid space. If there are 
more spaces on the grid than you have 
different images to add, repeat some.  You 

can flip or rotate the repeated images for variety.  Notice when you 
drag in a masked image, its background stays hidden. Each time you 
drag, the new image is added as a new layer in your grid document. 
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Create A Merged Layer 

When the grid is filled, inspect it once more to make certain there is 
no background showing, and that each small image is inside its grid 
space. Save the document at this point, with all its layers.  Having this 
backup will save time if you later decide to replace one or more of the 
small pictures to make a different pattern.  

This example is the filled grid for my second 
effort, a mixture of flower images in harmonizing 
colors.  I had nine unique images, repeated to fill 
the grid and some of them flipped or rotated.  
Notice the two similar pink flowers. Those were 
originally in a single photo, but I separated them so 
that they would scatter independently. 

The next step is very important, because the script 
won't work on a multi-layer document.  Right-click on 
any layer and choose Merge Visible. You also can 
access this option from the Layer menu. All the 
layers created as you dragged in images will condense 
into a single layer. Be sure to save the single layer 
version of the grid, because you can use it multiple 
times. Each time you run the script, you get a slightly 
different seamless pattern from the same grid. 
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Quick Tip: Why repeat images? Well, a 5 x 5 grid has 25 spaces in it, and it's 
easier to repeat images than to find 25 different ones.  In fact, 25 different 
images might make the design look too busy! The example in the online tutorial 
utilizes an array of a few similar images, some of them flipped, rotated, or 
slightly re-sized, to make a lovely tone-on-tone pattern. My example pattern 
employs a variety of shapes and harmonizing colors, but only nine unique images.  
Each is repeated twice and most appear in the grid three times.   
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Running The Script 
Go under the File menu, choose Scripts--> Browse, navigate to the 
random_pattern_fill.jsxbin file, and open the Image Scatter Script 
window.  Fill in the number of columns followed by the number of rows 
in your grid. Enter an output document size in pixels. The output 
document can be a different size and shape from the grid.  Enter the 
number of copies.  Double check that all the specifications are 
entered correctly, then click Create Texture.  Don't disturb the 
script in any way, because the (flashing) document it creates must be 
the topmost document. Good timing: You deserve a break at this point! 

Deciding How Many Copies 
You'll need to experiment to decide what value for number of copies 
works best for a particular grid.  The coverage in the pattern depends 
on many interacting factors: the size of the output document, the 
number and size of the grid images, the shape of the small images, the 
number of copies, and the variations available with the optional 
settings. Let's compare three examples. 
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In the first example, 500 copies of images from my flower grid 
completely cover the surface of a 2560 x 2560 pixel document. The 25 
flower images were 512 pixels wide.  Each roughly circular image mostly 
filled its grid space.  In the second experiment, with art from 
pixabay.com, I set up a grid with 15 images of small hardware items 
such as screws, bolts, and washers. These smaller images were only 300 
pixels wide. Many had a linear shape that filled less than half of its 
grid space. 500 copies (middle image above) left quite a bit of open 
space in a 3000 pixel square output document.  Even 1200 copies of 
hardware items (third example) didn't cover a 2560 x 2560 pixel 
output document as completely as 500 copies of the larger flowers.  

In these three examples, I added the green background to make open 
spaces stand out. I saved those open patterns, because there are ways 
to use scatter patterns with open spaces. More about that later! 

Optional Settings 
I haven't said anything about the many variations you 
can set in the script to generate slightly different 
effects with the same grid. Open the script window 
again and let's take a look at the options.  There are 
two sections, the top settings affecting the images 
and the bottom section affecting their drop shadows.  
The Shadow Layer variations are fairly standard for 
shadows, so I won't cover them in detail. 

The image Variations introduce a random factor into 
each parameter. For example, setting a Scale variation 
of 30 means the script will not only copy the images, 
but may vary the copies in size by up to 30%.  
Similarly, setting Rotate means the copies will 
randomly be rotated by up to the number of degrees 
you specify. If you put in 180, some of the images will be flipped 
completely over!   
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Assuming you are experienced with PhotoShop, you can probably guess 
what element each of the variations affect, but trying them out is the 
best way to really see what that change does to the pattern.   

In the two examples that follow, the left sample is from a pattern run 
with default settings, while the example on the right was set up for 
variation in rotation of 170, scale 30, and slight variations in hue, color 
balance and saturation.  It's a subtle difference, but notice that having 
different rotations disguises the repetition of images. You can easily 
see the color variations, but the results of the slight size variation 
setting are more difficult to spot.  Overall, the optional settings fine 
tune the design and make it more random. 
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Quick Tip: This scatter pattern is not solid, but that is not necessarily a 
flaw. I could add a solid layer below all the scatter group layers and fill it 
with a color to create multiple versions of this pattern. It might be 
perfect for custom wrapping paper! 
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Mask Option To Scatter Into A Shape 
You may have noticed a button on the Image Scatter dialog labeled 
Mask, and wondered what it's for.  It activates a fun and powerful 

option that lets you scatter images into a specific 
shape. Using Mask requires one extra step: making a 
separate mask document that serves as a stencil.  
You can download a folder of masks to try it out 
from my blog post about textures.com, but making a 
mask from scratch is quite easy.  Best of all, you can 
re-use each mask with any grid of images you have 

saved. The Mask option is another reason you should save all image 
grids you prepare for later possible re-use. 
 

Constructing A Mask  
Make a new PhotoShop document (I made mine 800 pixels 
square) with a black background. In a new layer, create a 
solid white shape. One method is to use Custom Shape 
tool, but be sure you have it set for Pixels. Quite a few likely shapes 
are loaded as presets, but you can load in more by clicking the smaller 

gear at the right of the Shapes dialog. You 
also can make a mask by typing large very 
thick bold text, draw a shape freehand and 
fill it, or lasso clip art and fill it. Avoid an 
intricate shape. The key is that any part of 
the mask that is white will be part of the 
pattern, while black areas are left empty. 
When you like the look of your mask, Merge 
the layers and save it. 

Using The Mask 
To use the mask, set up a grid of images (or open a saved one) as usual, 
then run the Image Scatter script. Fill in the usual information 
(number of rows and columns, output size, number of copies) but this 
time also click the Mask button.  When the script asks you to specify a 
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mask, navigate to folder of masks and choose one of them. From that 
point, the procedure is the same as without a mask. Click Create 
Texture and watch the pattern form! This may take up to ten minutes, 
and you will see lots of flashing and movement of layers. Be sure not to 
disturb the process until the shape is complete.   

Be Sure Output Is Square 
I have only found one quirk in using a mask: Be sure your output 
document is square. I had strange results if I used a mask when the 
output document was rectangular. In practice, this means you should 
set the output width and height to whichever is the maximum 
dimension you need. The mask can be rectangular, as was the mask for  
the THANK YOU! graphic. Run the script and create the textured 
shape in the square. If needed, crop off any excess surrounding space.  
That's how I finished the THANK YOU! graphic, cropping off a wide 
space above and below the text in the square output document.  

Here are a few more examples of scattered image shapes I made using 
masks.  Can't you just imagine that flower heart as part of a valentine?  
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The leaf arrow might be on a poster pointing the way to a fall book 
sale. The wreath could decorate a holiday greeting card. Being able to 
fill shapes with three dimensional images adds a whole new set of 
things you can create using the Image Scatter Script. 

 
Custom PhotoShop Fill Pattern 

Because any pattern you make with the Image 
Scatter Script is seamless, you can it as a 
pattern fill in PhotoShop.  In case you have 
never made a custom pattern fill, it's easy: 
Select the repeating area, in this case the 
entire scatter pattern, then choose Define 
Pattern... under Edit. Give your pattern a name 
and you're done! Your custom pattern will be 
listed as one of the pattern choices when you 
choose Fill with a pattern from the Edit menu, use the Paint Bucket 
set to fill with a pattern, set the Pattern Overlay layer effect, and 
for any other function using patterns.  

One caution: when you select the scatter 
pattern, be careful to do so from a merged 
layer. The Define Pattern... option only looks 
at the layer where you made your selection.  
I'm not sure what the maximum size selection 
you can define as a PhotoShop fill pattern.  

Practically, it would depend on your computer's system speed and 
amount of memory.  If you have trouble defining a very large selection, 
or if it slows things down when you try to use it as a fill pattern, re-
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Quick Tip: The Image Scatter script fills the output document with the mask, 
scattering images to the very edge. Some may hang out of the picture. For a 
margin like you see on the wreath and heart examples, choose Canvas Size 
under the Image menu, and increase the width and height. 
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size your scatter pattern and try again with a smaller size. I have 
defined a 3,000 pixel square selection as a fill pattern on my system 
without any problem. 

Fill Commands Use The Pattern At Full Size 
When you use your custom pattern with Fill, Brush, or the Paint 
Bucket, you are limited to the original scale of the pattern.  For that 
reason, you may want to downsize and define several versions of your 
seamless design as separate custom patterns. For example, I scattered 
leaf photos in a 3000 pixel square document, so that's the original size 
of the fill pattern I could define. If I poured that into a 1000 pixel 
square document, I wouldn't even see all of one motif!  

If I filled a 6000 pixel square, the leaf pattern still would repeat only 
twice across and two times top to bottom.  For more repeats, I would 
have to downsize my scattered leaf document, perhaps to 1000 x 1000 
pixels, and define a second pattern from that size. Filling with this 
smaller scale pattern,  I would see six repeats across and six repeats 
down in the 6000 pixel square.  Of course I could also define a 500 
pixel wide pattern, which would give me 12 repeats across. If I 
continued to reduce the size, though, at some point I would lose detail 
and the pattern wouldn't look good. 

Pattern Overlay Can Be Scaled 
Another option for using a fill pattern, Pattern 
Overlay, lets you scale the pattern.  It is applied to 
an entire layer. Of course, in PhotoShop that layer 
could have any shape on it, but let's begin by using 
Pattern Overlay on an entire layer.  Make a new 
document and double-click the default Background 
layer to convert it to a normal layer. Fill the blank 
layer with any solid color, then double-click the 
layer, or right-click it to open its menu and choose 
Blending Options. You also can open Blending 
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Options by clicking fx at the bottom of the Layers palette. Choose 
Pattern Overlay from the Blending Options list and open its dialog 

window by clicking the words Pattern 
Overlay.  Initially the default pattern will be 
chosen, but you can open the Patterns 
Presets by clicking the small V to the right of 
the sample window. Choose your custom 
pattern, then close the Pattern Presets 
samples.The entire  layer will be covered with 

your pattern at its default scale. It doesn't matter what color you 
used to fill the layer. Any area that is not transparent will be covered 
with the pattern overlay. 

With the Pattern Overlay dialog still open, experiment with moving the 
Scale slider located just below the sample window. You can vary the 
size of the pattern repeating unit from a tiny size up to a size that is 
larger than the layer.  

Paint A Scaled Pattern 
Let's continue experimenting by making a new blank layer. Then select 
the layer with the pattern overlay, right-click it in the Layers palette, 
and this time choose Copy Layer Style from the menu. Return to the 
new blank layer, right-click it to open its menu, and choose Paste 
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Layer Style. You won't see any change at first, 
except that a new label appears in the blank 
layer saying that it now has a Pattern Overlay 
effect. Hide the layer that has the pattern 
overlay by clicking the eye icon to its left, then 
choose the blank layer again.  

Get a painting tool such as the brush, and paint in the blank layer. 
Regardless of the current foreground color, you seem to be painting 
with your custom pattern, because any opaque area in the layer will 

display the pattern overlay. Of course, you 
could also use the Pattern Stamp tool to paint a 
pattern, but that only allows you to paint the 
pattern at its default scale.  The Pattern 
Overlay trick gives you a way to paint patterns, 
including your custom patterns, at any scale.  

A Few Final Thoughts 
Besides the ability to paint a scaled pattern freehand on a blank layer 
if it has a Pattern Overlay effect, you can create patterned shapes. 
Regardless of the original colors, if you create a filled shape or paste a 
piece of clip art into a layer with a Pattern Overlay, it will appear 
filled with the pattern, at whatever scale you have set.  

You can use a mask on a filled layer that has a Pattern Overlay. Only  
areas affected by the visible part of the mask will show, and those 
areas will have the pattern.  

Did you notice that the wreath has a lot more 
spruce twigs than the accent items such as berries 
and cones? I planned it to come out that way by 
repeating the spruce twigs many more times in the 
grid I used to generate the pattern. The exact 
placement of images in the scatter pattern changes 
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each time you run the Image Scatter script, but you can control the 
overall effect somewhat by adjusting the proportions of specific 
images. 

Besides using the seamless patterns created with the Image Scatter 
Script for projects like web page, desktop, and other backgrounds, you 
can make off-computer projects. While not free, there are many 
websites that let you upload a seamless motif and have it printed as 
wrapping paper, wallpaper, or fabric. Of course, you can easily make 
small sheets of wrapping paper with any printer. 

If you want to simplify a layer so that 
you aren't dealing with layer effects, 
masks, and such, create a merged layer. 
Right-click a layer, making sure you are 
clicking above the Effects details, and 
choose Merge Visible from the layer 
menu. If you hold the alt/option key as 
you do this, PhotoShop makes a new 
layer incorporating all the visual effects 
in one simple layer, but leaves all other layers unchanged.  

If you choose Merge Visible without the modifier key, PhotoShop 
actually merges all layers, leaving you with one simple layer. 
Alternately, if your document has only one layer, or you are certain you 
won't need the other layers, you could choose Flatten Image from the 
same menu. 

Crazy Fun Using Pattern Overlay With Blend Modes 
I've said that Pattern Overlay completely obscures whatever color you 
use to fill a layer, but there is one exception. You can set the overlay 
to blend with the color in the layer it covers. You have the same 
choices of different blend modes as are available to blend one layer 
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with another, but in this case blend mode only affects how the pattern 
overlay interacts with the layer's fill color.   

To try out this option, start a new blank document, convert Background 
to simple layer, and fill the layer with a solid color. Right-click the 
layer and choose Blending Options-->Pattern Overlay. Choose your 

custom pattern. Before closing the 
dialog, choose one of the Blend Modes 
other than the default Normal for the 
overlay. You can see the full list by 
clicking the double arrow to the right of 
the words Blend Mode:. As soon as you 
choose a Blend Mode other than 
Normal, you will see the effect. 

With Blend Modes active, because the seamless pattern blends with 
the color you used to fill the layer, the color you use for the fill does 
change the appearance of the pattern overlay. Experiment! I can't 
predict what effects you will come up with, but I know you'll be 
surprised and delighted.  

Try out all the Blend Modes, then see what happens if you set the 
blend to less than 100% opacity. Try out different fill colors for the 
layer. Try setting various patterns for the overlay at various scales. 
See what happens when you fill the layer with a gradient, and then 
blend in a Pattern Overlay. One interesting effect: If you enlarge your 
document, the pattern keeps the same scale and does not lose detail. 

The following examples are a few of my experiments, all with the pink 
to purple flowers pattern. First I used a blue fill on the layer and tried 
various blend modes. Then I tried filling the layer with a rainbow 
gradient and blending the flowers pattern, again using several 
different modes.   
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Original Fill Pattern Scale 31% Blue Layer Fill 

 

Pattern Overlay Blend Mode Hard Light 
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Pattern Blend Mode Difference 100% Opacity 

 

Pattern Blend Mode Difference 50% Opacity 
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Pattern Overlay Blend Mode Subtract 

Pattern Overlay Blend Mode Luminosity 
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Rainbow Fill, Scale 19%, Pattern Blend Mode Difference 

Rainbow Fill, Scale 19%, Pattern Blend Mode Hue 
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Guide To Topics 

Downloading The Image Scatter Script 1 

Running Scripts In PhotoShop 1 

Seamless Patterns 2 

Planning The Image Grid Dimensions 2-3  

Re-Sizing The Images 3 

Creating Grid Guide Lines 4 

Sources Of Images To Scatter 4-6 

Filling The Grid With Images 6-7  

Running The Image Scatter Script 8-10 

Mask Option: Scatter Into A Shape 11-13 

Defining A Custom Fill Pattern 13-14 

Using The Pattern Overlay Effect 14-16 

Final Thoughts 16-17 

Using Pattern Overlay With Blend Modes 17-22 
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This tutorial was downloaded from Annie's Resource Attic and is copyright 
2017 by ann brundige studio. You may make and distribute as many copies as 
you want, but must include this page. You may not sell this activity, nor use any 
of its elements for commercial purposes. For details regarding this Creative 
Commons license, see the Terms of Use section of the web page at 
www.annbrundige studio.com . 

Illustrations and screenshots in this tutorial are by Ann Brundige (2017) (CC 
BY-NC-SA 2.0). Images used with the scatter script were all downloaded from 
textures.com, except for the following: 

2296968640_2839e42874_b.jpg blue spruce-1Picea pungens var. glauca by 
Maggie (2008) (CC BY-NC 2.0) via flickr.com. 

2997687598_ce6918f644_b.jpg blue spruce twigs by Andee Duncan (2008) 
(CC BY-NC 2.0) via flickr.com. 

2258805426_11e9d2c59b_z.jpg Pine Cone by justclaire (2008) (CC BY-NC-
SA 2.0) via flickr.com. 

4041187412_da37f50abf_z.jpg Pine Cone by paulerogers (2006) (CC BY-NC-
SA 2.0) via Flickr.com. 
6503108095_503f375a92_o.png FR0004_Christmas_Holly 250x500px PNG 
by SALi-design (2008) (CC BY-NC 2.0) via flickr.com. 

6396525403_66211b2f4e_z.jpg Holly by Dendroica cerulea (2011) (CC BY-
NC-SA 2.0) via flickr.com. 


